v2 web admin - ALARM: "AWS Predicted Cost Anomaly alarm" in US East (N. Virginia)

Incident Report for fraud.net

Resolved

This incident has been resolved.
Posted May 17, 2021 - 09:50 UTC

Investigating

{
"AlarmName": "AWS Predicted Cost Anomaly alarm",
"AlarmDescription": "Idea is to use ML anomaly detection to notify us when cost get out of hand.",
"AWSAccountId": "393915070316",
"NewStateValue": "ALARM",
"NewStateReason": "Thresholds Crossed: 1 out of the last 1 datapoints [24514.27 (15/05/21 00:09:00)] was greater than the upper thresholds [24468.642165428893] (minimum 1 datapoint for OK -> ALARM transition).",
"StateChangeTime": "2021-05-16T00:09:09.759+0000",
"Region": "US East (N. Virginia)",
"AlarmArn": "arn:aws:cloudwatch:us-east-1:393915070316:alarm:AWS Predicted Cost Anomaly alarm",
"OldStateValue": "OK",
"Trigger": {
"Period": 86400,
"EvaluationPeriods": 1,
"ComparisonOperator": "GreaterThanUpperThreshold",
"ThresholdMetricId": "ad1",
"TreatMissingData": "- TreatMissingData: missing",
"EvaluateLowSampleCountPercentile": "",
"Metrics": [
{
"Id": "m1",
"MetricStat": {
"Metric": {
"Dimensions": [
{
"value": "USD",
"name": "Currency"
}
],
"MetricName": "EstimatedCharges",
"Namespace": "AWS/Billing"
},
"Period": 86400,
"Stat": "Maximum"
},
"ReturnData": true
},
{
"Expression": "ANOMALY_DETECTION_BAND(m1, 0.05)",
"Id": "ad1",
"Label": "EstimatedCharges (expected)",
"ReturnData": true
}
]
}
}


code:
{
"Type": "Notification",
"MessageId": "2a0b7b1e-6782-5941-833d-2204036789df",
"TopicArn": "arn:aws:sns:us-east-1:393915070316:opsgenie",
"Subject": "ALARM: \"AWS Predicted Cost Anomaly alarm\" in US East (N. Virginia)",
"Message": "{\"AlarmName\":\"AWS Predicted Cost Anomaly alarm\",\"AlarmDescription\":\"Idea is to use ML anomaly detection to notify us when cost get out of hand.\",\"AWSAccountId\":\"393915070316\",\"NewStateValue\":\"ALARM\",\"NewStateReason\":\"Thresholds Crossed: 1 out of the last 1 datapoints [24514.27 (15/05/21 00:09:00)] was greater than the upper thresholds [24468.642165428893] (minimum 1 datapoint for OK -> ALARM transition).\",\"StateChangeTime\":\"2021-05-16T00:09:09.759+0000\",\"Region\":\"US East (N. Virginia)\",\"AlarmArn\":\"arn:aws:cloudwatch:us-east-1:393915070316:alarm:AWS Predicted Cost Anomaly alarm\",\"OldStateValue\":\"OK\",\"Trigger\":{\"Period\":86400,\"EvaluationPeriods\":1,\"ComparisonOperator\":\"GreaterThanUpperThreshold\",\"ThresholdMetricId\":\"ad1\",\"TreatMissingData\":\"- TreatMissingData: missing\",\"EvaluateLowSampleCountPercentile\":\"\",\"Metrics\":[{\"Id\":\"m1\",\"MetricStat\":{\"Metric\":{\"Dimensions\":[{\"value\":\"USD\",\"name\":\"Currency\"}],\"MetricName\":\"EstimatedCharges\",\"Namespace\":\"AWS/Billing\"},\"Period\":86400,\"Stat\":\"Maximum\"},\"ReturnData\":true},{\"Expression\":\"ANOMALY_DETECTION_BAND(m1, 0.05)\",\"Id\":\"ad1\",\"Label\":\"EstimatedCharges (expected)\",\"ReturnData\":true}]}}",
"Timestamp": "2021-05-16T00:09:09.853Z",
"Signature": "g7K0r+66ViuwjvUu0Hql2D1JkRIEQOEKEiV0e40FnznSi/9ndg/zyLeCbcW5CdK+/whmMsK/DSQHb0aZbxTJUIIMd0o68rs+aonHEVV+JRg0NVcgUG1t7tY82Xmf5MBLcQ/I6/IIvnlC6Jz94i+WEi7CJkooKgLg+sX62t5Hac8cg5SCpRiq6+KKKm3e2u07m+R2AnwJ1X5XC/+Za3ylmeSC1F5tskd38ZFtbYavSIP3d9ZgFtifYIMfTUZmOFxoRxJHvI4lDcZtUei4nHybtm1t0ck3VJXgioVI5vhvrl1BHUUGjlAfCzSAP6mDdJa+v9AwLQMhIQ6RU/yvxKA91w=="
}
Posted May 16, 2021 - 00:09 UTC